Site loading issues
Incident Report for Buycraft
Resolved
Site load has stabilised, and we in discussions with our hardware vendors to look at new infrastructure in order to better cope with future events.
Posted over 1 year ago. Dec 27, 2016 - 17:50 GMT
Investigating
We're receiving unexpected spikes in traffic, we are working on resolving the problem and will keep you updated.
Posted over 1 year ago. Dec 26, 2016 - 14:37 GMT