Connectivity issues
Incident Report for Buycraft
Resolved
We have restored connectivity to the website. We apologise for any inconvenience caused.
Posted over 1 year ago. Dec 11, 2016 - 22:51 GMT
Update
We have identified the cause of the connectivity issues and we are working on resolving the problem.
Posted over 1 year ago. Dec 11, 2016 - 22:51 GMT
Investigating
We are aware of connectivity issues with the website and we are investigating the cause. We will update you as soon as we know more.
Posted over 1 year ago. Dec 11, 2016 - 22:51 GMT