Webstore issues
Incident Report for Buycraft
Resolved
All issues have now been resolved and fully tested.
Posted 11 months ago. Jun 23, 2017 - 11:09 BST
Monitoring
We have pushed a fix for the issues and are continuing to test this resolution.
Posted 11 months ago. Jun 23, 2017 - 10:53 BST
Investigating
We're currently investigating an issue with purchasing on webstores. We will post updates as soon as we have them.
Posted 11 months ago. Jun 23, 2017 - 10:36 BST