Site loading issues
Incident Report for Buycraft
Resolved
Our new mitigation scheme appears to be working as expected. As always we will continue to monitor for new threats and apply new mitigation strategies as appropriate.
Posted 11 months ago. Jun 14, 2017 - 07:54 BST
Monitoring
We have been working on developing a new mitigation strategy and will continue to monitor this going forward.
Posted 11 months ago. Jun 13, 2017 - 23:00 BST
Investigating
We're currently working on mitigating some excessive traffic on the site. We will post further updates as we have them.
Posted 11 months ago. Jun 13, 2017 - 19:34 BST