Site loading issues
Incident Report for Buycraft
Resolved
Confirmed traffic levels are back to normal and we are continuing to work on further mitigation with Cloudflare.
Posted 11 months ago. Jul 07, 2017 - 09:28 BST
Monitoring
We've identified a number of traffic sources with CloudFlare, and are working with them to identify how to best mitigate.
Posted 11 months ago. Jul 06, 2017 - 15:51 BST
Investigating
We are currently looking into some downtime issues and will post further information as we investigate.
Posted 11 months ago. Jul 06, 2017 - 13:33 BST