Slow load times
Incident Report for Buycraft
Resolved
Site stability is back to normal. We're monitoring the situation closely over the next few hours.
Posted over 1 year ago. Dec 22, 2016 - 20:59 GMT
Monitoring
We're currently working on improving site loading times due to an unexpected surge in traffic. We'll keep you updated as we progress.
Posted over 1 year ago. Dec 22, 2016 - 19:05 GMT